Computer >> कंप्यूटर ट्यूटोरियल >  >> प्रणाली >> Windows

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

इस लेख में, हम चर्चा करने जा रहे हैं कि SNMP क्या है और विंडोज 10 में SNMP सर्विस को कैसे इंस्टॉल या इनेबल और कॉन्फिगर करें। SNMP जिसका मतलब सिंपल नेटवर्क मैनेजमेंट प्रोटोकॉल है, एक मानक इंटरनेट प्रोटोकॉल है जिसका उपयोग IP पर जुड़े कई नेटवर्किंग डिवाइस के बीच संचार को नियंत्रित और प्रबंधित करने के लिए किया जाता है। यह संगठनों को राउटर, वर्कस्टेशन, मोडेम, स्विच, सर्वर, प्रिंटर आदि सहित विभिन्न नेटवर्किंग डिवाइस की निगरानी करने में सक्षम बनाता है। SNMP अधिकांश नेटवर्किंग डिवाइस पर पहले से कॉन्फिगर होता है। और, एक बार प्रोटोकॉल इनेबल हो जाने पर, डिवाइस परफॉर्मेंस स्टैटिस्टिक्स स्टोर हो जाते हैं।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

आइए अब SNMP के मुख्य घटक पर चर्चा करें।

SNMP के मुख्य घटक

यहां SNMP-प्रबंधित वातावरण के प्रमुख घटक हैं:

SNMP मैनेजर: यह केंद्रीय सिस्टम है जो SNMP नेटवर्क को प्रबंधित और मॉनिटर करता है। इसे नेटवर्क मैनेजमेंट स्टेशन (NMS) के रूप में भी जाना जाता है और नेटवर्क पर एक होस्ट पर चलता है। SNMP मैनेजर मूल रूप से SNMP एजेंट से क्वेरी करता है, अनुरोध प्राप्त करता है,

SNMP एजेंट: यह एक सॉफ्टवेयर प्रक्रिया है जो SNMP क्वेरी प्राप्त होने पर नेटवर्क नोड की स्थिति और आंकड़े देता है। यह SNMP प्रबंधन में एक महत्वपूर्ण घटक है जो मॉनिटरिंग डेटा को एकत्र करता है, स्टोर करता है, और SNMP मैनेजर्स को प्रसारित करता है।

प्रबंधित डिवाइस: इन डिवाइस में वे सभी SNMP-इनेबल्ड नेटवर्किंग डिवाइस शामिल हैं जिन्हें आप मॉनिटर करना चाहते हैं, जैसे प्रिंटर, राउटर, वायरलेस डिवाइस, आदि।

SNMP MIB: SNMP ऑब्जेक्ट आइडेंटिफायर (OIDs) नेटवर्क एंटिटी मैनेजमेंट के साथ हायरार्की के रूप में परिभाषित मैनेजमेंट इंफॉर्मेशन बेस (MIB) के साथ एक एक्स्टेंसिबल डिज़ाइन का उपयोग करता है। इसे मुख्य रूप से SNMP मैनेजमेंट मॉडल में सूचना विनिमय के प्रारूप के रूप में परिभाषित किया गया है। प्रत्येक नेटवर्क सर्वर में MIB फाइलें होती हैं जिन्हें मॉनिटरिंग डेटा एकत्र करने के लिए क्वेरी किया जाता है।

SNMP OID: OID यानी ऑब्जेक्ट आइडेंटिफायर MIB डेटाबेस में ट्री स्ट्रक्चर में व्यवस्थित होते हैं जहां सभी उत्पादों की प्रबंधनीय विशेषताएं मौजूद होती हैं।

SNMP संस्करण

SNMP के मूल रूप से तीन संस्करण हैं जो हैं:

  1. SNMPv1: SNMP प्रोटोकॉल का पहला संस्करण जो RFC 1155 और 1157 में परिभाषित है।
  2. SNMPv2c: यह उन्नत संस्करण है और RFC 1901, RFC 1905, और RFC 1906 में परिभाषित है।
  3. SNMPv3: अब तक का SNMP का अंतिम संस्करण जो SNMP एंटिटी के रिमोट कॉन्फिगरेशन को भी बढ़ावा देता है। यह अब तक का सबसे सुरक्षित संस्करण है और RFC 1905, RFC 1906, RFC 2571, RFC 2572, RFC 2574, और RFC 2575 में परिभाषित है।

बुनियादी SNMP कमांड

नेटवर्क मैनेजमेंट मॉडल में उपयोग की जाने वाली मुख्य SNMP कमांड यहां दी गई हैं”

  • GET: SNMP मैनेजर एक या अधिक मान प्राप्त करने के लिए प्रबंधित डिवाइस को GET अनुरोध भेजता है।
  • GET NEXT: इस कमांड का उपयोग MIB ट्री में अगले OID मान को पुनः प्राप्त करने के लिए किया जाता है
  • GET BULK: इस कमांड का उपयोग बड़े MIB टेबल से बल्क डेटा क्वेरी और पुनः प्राप्त करने के लिए किया जाता है।
  • SET: प्रबंधित डिवाइस के मानों को संपादित या जोड़ने के लिए, इस कमांड का उपयोग SNMP मैनेजर्स द्वारा किया जाता है।
  • TRAPS: ऐसी कमांड SNMP एजेंट द्वारा शुरू की जाती है ताकि घटनाएं होने पर SNMP मैनेजर को सिग्नल भेजा जा सके।
  • INFORM: SNMP एजेंट द्वारा शुरू की गई एक अन्य कमांड जिसमें SNMP मैनेजर द्वारा संदेश प्राप्त होने पर पुष्टि शामिल होती है।
  • RESPONSE: यह कमांड SNMP मैनेजर द्वारा निर्देशित कार्यों के मान या सिग्नल को वापस ले जाती है।

IT संगठन PRTG नेटवर्क मॉनिटर या Spiceworks नेटवर्क मॉनिटर जैसे समर्पित SNMP मॉनिटरिंग सॉफ्टवेयर का उपयोग करके नेटवर्किंग डिवाइस और परफॉर्मेंस स्टैटिस्टिक्स को प्रबंधित और मॉनिटर कर सकते हैं। यहां SNMP मॉनिटरिंग टूल के कुछ सामान्य उपयोग हैं:

  • इसका उपयोग किसी संगठन में नेटवर्क डिवाइस को खोजने, प्रबंधित करने, व्यवस्थित करने और मॉनिटर करने के लिए किया जाता है।
  • यह नेटवर्क डिवाइस के प्रदर्शन की पूरी दृश्यता सक्षम करता है।
  • कनेक्टेड नेटवर्क डिवाइस के विभिन्न आंकड़ों और सूचनाओं का विश्लेषण करें जैसे कनेक्टिविटी, उपलब्धता, प्रदर्शन, बैंडविड्थ, ट्रैफिक, नेटवर्क उपयोग ग्राफ, और अधिक।
  • यह नेटवर्क उपयोग के लिए थ्रेशोल्ड सीमा सेट करने की अनुमति देता है।
  • यह आपको अपवादों या विसंगतियों के मामले में अलर्ट ट्रिगर करने देता है।

अब, आइए देखें कि आप विंडोज 10 पर SNMP सर्विस को कैसे इंस्टॉल और इनेबल कर सकते हैं और फिर इसे कॉन्फिगर कर सकते हैं।

विंडोज 11/10 में SNMP सर्विस कैसे इंस्टॉल और इनेबल करें

SNMP विंडोज के पुराने संस्करणों में एक प्रीइंस्टॉल्ड फीचर हुआ करता था। हालांकि, SNMP अब अप्रचलित माना जाता है और विंडोज 10 संस्करण 1809 और बाद में एक वैकल्पिक फीचर/डिमांड पर फीचर (FOD) बना दिया गया है। विंडोज अब कॉमन इंफॉर्मेशन मॉडल (CIM) का उपयोग करने की सिफारिश करता है जो विंडोज रिमोट मैनेजमेंट द्वारा समर्थित है।

नवीनतम विंडोज 10 बिल्ड में, SNMP को सेटिंग्स ऐप का उपयोग करके वैकल्पिक फीचर विकल्प के माध्यम से इंस्टॉल और इनेबल किया जा सकता है।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

सेटिंग्स का उपयोग करके विंडोज 10 में SNMP को इनेबल और कॉन्फिगर करने के चरण यहां दिए गए हैं:

  1. विंडोज + I हॉटकी दबाकर सेटिंग्स ऐप खोलें।
  2. ऐप्स कैटेगरी पर जाएं और ऐप्स और फीचर्स टैब पर जाएं।
  3. वैकल्पिक फीचर्स बटन पर टैप करें।
  4. नए पेज पर, एक फीचर जोड़ें बटन पर क्लिक करें।
  5. सिंपल नेटवर्क मैनेजमेंट प्रोटोकॉल (SNMP) तक नीचे स्क्रॉल करें और इसे चुनें।
  6. अपने पीसी पर SNMP इनेबल करने के लिए इंस्टॉल बटन दबाएं।

आप कंट्रोल पैनल का उपयोग करके अपने कंप्यूटर पर SNMP को इनेबल भी कर सकते हैं यदि आप पुराने विंडोज 10 बिल्ड या यहां तक कि विंडोज 8 का उपयोग करते हैं।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

उसके लिए बस निम्न चरणों का उपयोग करें:

  1. विंडोज + R का उपयोग करके रन खोलें और इसमें "कंट्रोल पैनल" दर्ज करें और एंटर दबाएं।
  2. प्रोग्राम्स और फीचर्स पर जाएं और फिर विंडोज फीचर्स ऑन या ऑफ विकल्प पर क्लिक करें।
  3. विंडोज फीचर्स सूची में, सिंपल नेटवर्क मैनेजमेंट प्रोटोकॉल (SNMP) चुनें और इसे इंस्टॉल करने के लिए OK दबाएं।

विंडोज 10 में SNMP सर्विस कैसे कॉन्फिगर करें

इंस्टॉल करने के बाद, आपको विंडोज 10 में SNMP सर्विस को कॉन्फिगर करने की आवश्यकता है। दो मुख्य SNMP सर्विसेज हैं जिनमें शामिल हैं:

  • SNMP सर्विस – निगरानी और जानकारी भेजने के लिए मुख्य सर्विस
  • SNMP ट्रैप – SNMP एजेंटों से ट्रैप मैसेज प्राप्त करने और उन्हें SNMP मैनेजमेंट सॉफ्टवेयर पर अग्रेषित करने के लिए।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

SNMP इंस्टॉलेशन के बाद ये सर्विसेज स्वचालित रूप से शुरू होनी चाहिए। आप सर्विसेज मैनेजर से इन्हें जांच और कॉन्फिगर कर सकते हैं। बस रन डायलॉग को खोलने के लिए विंडोज + R हॉटकी दबाएं और इसमें "services.msc" दर्ज करें। सर्विसेज विंडो में, सूची में SNMP सर्विस तक नीचे स्क्रॉल करें और देखें कि यह चल रही है या नहीं। यदि यह नहीं चल रही है, तो बस SNMP सर्विस शुरू करने के लिए प्रारंभ बटन पर क्लिक करें। साथ ही, इसके स्टार्टअप प्रकार को ऑटोमेटिक पर सेट करें।

आप एजेंट, सुरक्षा आदि सहित विभिन्न SNMP सर्विस प्रॉपर्टीज को आगे सेट कर सकते हैं। बस SNMP सर्विस पर राइट-क्लिक करें और गुण विकल्प चुनें।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

गुण विंडो में, एजेंट टैब पर जाएं जहां आप SNMP एजेंट जानकारी कॉन्फिगर कर सकते हैं। आप यूजर या एडमिनिस्ट्रेटर का संपर्क नाम और कंप्यूटर का भौतिक स्थान निर्दिष्ट करने के लिए संपर्क और स्थान विवरण जोड़ सकते हैं। इसके अलावा, आप उस सूची से पांच सर्विसेज को इनेबल या डिसेबल कर सकते हैं जिनसे आप मॉनिटरिंग डेटा प्राप्त करते हैं और इसे मॉनिटरिंग डिवाइस पर भेजते हैं। इन सर्विसेज में फिजिकल, एप्लिकेशन, डेटालिंक और सबनेटवर्क, इंटरनेट, और एंड-टू-एंड शामिल हैं।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें

विभिन्न SNMP सर्वर्स के लिए कुछ सुरक्षा-संबंधी सेटिंग्स कॉन्फिगर करने के लिए, आप गुण विंडो में सुरक्षा टैब पर जा सकते हैं। स्वीकृत कम्युनिटी नामों की सूची में, आप SNMP होस्ट देख सकते हैं और जोड़ सकते हैं जो SNMP अनुरोध भेजने के लिए प्रमाणित हैं। एक कम्युनिटी जोड़ने के लिए, Add बटन पर क्लिक करें और कम्युनिटी नाम टाइप करें। आप किसी विशेष कम्युनिटी को कोई नहीं, सूचित करें, केवल पढ़ें, पढ़ें लिखें, या पढ़ें बनाएं एक्सेस प्रदान कर सकते हैं।

आप इन होस्ट से SNMP पैकेट स्वीकार करें की सूची में IP पतों के साथ SNMP मॉनिटरिंग सर्वर्स की सूची जोड़ सकते हैं। यह उन सर्वर्स को निर्दिष्ट करने के लिए है जिनसे SNMP पैकेट स्वीकार किए जाते हैं। यदि आप किसी भी होस्ट से SNMP पैकेट स्वीकार करें विकल्प इनेबल करते हैं, तो SNMP एजेंट पर SNMP पैकेट प्राप्त करने के लिए कोई IP प्रतिबंध लागू नहीं होगा। यह विकल्प सुरक्षित नहीं है और इसलिए पब्लिक कंप्यूटर पर अनुशंसित नहीं है।

IT एडमिन SNMP से संबंधित कुछ अन्य सेटिंग्स को आगे कॉन्फिगर कर सकते हैं और SNMP मैनेजमेंट सॉफ्टवेयर और टूल्स का उपयोग करके सभी कनेक्टेड नेटवर्किंग डिवाइस को मॉनिटर कर सकते हैं।

उम्मीद है, इस लेख ने आपको SNMP प्रोटोकॉल के बारे में जानने और विंडोज 10 में SNMP सर्विस को कैसे इनेबल और कॉन्फिगर करें, इसमें मदद की।

अब पढ़ें: विंडोज 11/10 के लिए फ्री नेटवर्क और इंटरनेट ट्रैफिक मॉनिटर टूल्स।

विंडोज 11/10 में SNMP सर्विस कैसे इनेबल और कॉन्फिगर करें
  1. Windows 11/10 में ऑटोप्ले डिफॉल्ट कैसे सक्षम, कॉन्फिगर और सेट करें Windows 11/10 में ऑटोप्ले डिफॉल्ट कैसे सक्षम, कॉन्फिगर और सेट करें

    Windows 11/10 में ऑटोप्ले डिफॉल्ट सेट करें Windows 10 आपको Settings ऐप के माध्यम से मीडिया, डिवाइस और फोल्डर्स के लिए ऑटोप्ले डिफॉल्ट आसानी से सेट करने देता है। Windows ऑटोप्ले फीचर उपयोगकर्ताओं के लिए एक अच्छी सुविधा है जब वे CD\DVD, USB, या मेमोरी कार्ड के माध्यम से मीडिया डालते हैं। ऑटोप्ले आपको

  1. Windows 11/10 पर XAMPP इंस्टॉल और कॉन्फ़िगर कैसे करें Windows 11/10 पर XAMPP इंस्टॉल और कॉन्फ़िगर कैसे करें

    XAMPP एक मुफ्त और ओपन-सोर्स टूल है जिसका उपयोग मूल रूप से टेस्टिंग उद्देश्यों के लिए अपनी साइट की स्थानीय प्रति बनाने के लिए किया जाता है। यह एक हल्का और क्रॉस-प्लेटफॉर्म एप्लिकेशन है जो वेब डेवलपर्स के लिए अपने प्लगइन्स, थीम, और अन्य चीजों को टेस्ट करना काफी सरल बनाता है। Xampp Apache और MySQL के स

  1. विंडोज 11/10 में पिन कॉम्प्लेक्सिटी ग्रुप पॉलिसी सक्षम और कॉन्फ़िगर कैसे करें विंडोज 11/10 में पिन कॉम्प्लेक्सिटी ग्रुप पॉलिसी सक्षम और कॉन्फ़िगर कैसे करें

    पिन कॉम्प्लेक्सिटी ग्रुप पॉलिसी आप अपने उपयोगकर्ताओं को विंडोज 11/10 या विंडोज सर्वर में साइन इन करने के लिए अंक, लोअरकेस, अपरकेस और विशेष वर्णों का उपयोग करके एक जटिल पिन बनाने के लिए बाध्य कर सकते हैं, पिन कॉम्प्लेक्सिटी ग्रुप पॉलिसी को सक्षम करके। साइन-इन विकल्प खोलना होगा। यहां, पिन के तहत आपको