Computer >> कंप्यूटर ट्यूटोरियल >  >> नेटवर्किंग >> नेटवर्क सुरक्षा

नेटवर्क सुरक्षा में MD5 क्या है?

MD5 हैश फंक्शन: नेटवर्क सुरक्षा में उपयोग और सीमाएं

MD5 क्या है और यह कैसे काम करता है?

MD5 (Message Digest Algorithm 5) एक क्रिप्टोग्राफिक हैश फंक्शन है जो किसी भी लंबाई के इनपुट संदेश से 128-बिट (16-बाइट) हैश मान उत्पन्न करता है। यह एक "मैसेज डाइजेस्ट" या "फिंगरप्रिंट" बनाता है जो इनपुट डेटा के लिए अद्वितीय होता है।

MD5 का क्या अर्थ है?

MD5 का अर्थ है Message Digest Algorithm 5। SHA1 का अर्थ है Secure Hash Algorithm 1। MD5 मैसेज डाइजेस्ट की लंबाई 128 बिट तक हो सकती है। SHA1 मैसेज डाइजेस्ट 160 बिट तक लंबा हो सकता है।

MD5 कैसे गणना की जाती है?

  1. टर्मिनल प्रोग्राम चलाएं
  2. टर्मिनल विंडो में टाइप करें: md5sum [फाइल नाम एक्सटेंशन के साथ] [फाइल का पथ]
  3. नोट: आप फाइल को टर्मिनल विंडो में ड्रैग भी कर सकते हैं
  4. Enter दबाएं
  5. यह MD5 सम प्रदर्शित करेगा
  6. नए मान की तुलना मूल मान से करें

इसे MD5 क्यों कहा जाता है?

MD5 (चेकसम): यह मैसेज डाइजेस्ट (5) के समान है। आमतौर पर एक फाइल और उसकी सामग्री का उपयोग हैश मान उत्पन्न करने के लिए किया जाता है, जिसे आमतौर पर चेकसम कहा जाता है, लेकिन यह वास्तव में एक नहीं है।

MD5 कितना सुरक्षित है?

महत्वपूर्ण: MD5 को अब क्रिप्टोग्राफिक रूप से सुरक्षित नहीं माना जाता है। 2004 से ज्ञात टकराव हमलों (collision attacks) के कारण, MD5 को डिजिटल हस्ताक्षर और SSL प्रमाणपत्र जैसे सुरक्षा-महत्वपूर्ण अनुप्रयोगों के लिए अप्रचलित माना जाता है।

MD5 या SHA: कौन अधिक सुरक्षित है?

MD5, SHA1 से तेज है, लेकिन SHA1 की गति नोटिस करने योग्य रूप से धीमी है। हालांकि SHA1, MD5 की तुलना में उच्च स्तर की सुरक्षा प्रदान करता है, लेकिन यह उतना सुविधाजनक नहीं है। SHA-256 और SHA-3 वर्तमान में अनुशंसित मानक हैं।

क्या MD5 अप्रचलित है?

हां, NIST द्वारा MD5 को अप्रचलित घोषित किया गया है (दस्तावेज़ NISTSP800-131A-R2 देखें)। RFC5246 और RFC7525 में MD5 और SHA1 को अपडेट किया गया है ताकि उन्हें क्रिप्टोग्राफिक हैश फंक्शन के रूप में उपयोग न किया जा सके।

MD5 चरण-दर-चरण कैसे काम करता है?

  1. पैडिंग बिट्स जोड़ें: मूल डेटा में अतिरिक्त डेटा जोड़ना
  2. मूल इनपुट लंबाई रिकॉर्ड करें: पैडिंग के बाद डेटा के अंत में 64 बिट्स
  3. MD बफर इनिशियलाइज़ करें: चार 32-बिट रजिस्टर (A, B, C, D)
  4. संदेश को 16-शब्द ब्लॉक में विभाजित करें: प्रत्येक 512-बिट ब्लॉक को प्रोसेस करें
  5. 4 राउंड प्रोसेसिंग: प्रत्येक राउंड में 16 ऑपरेशन
  6. आउटपुट: 128-बिट हैश मान

क्या MD5 अभी भी उपयोग किया जाता है?

वर्षों से शोषित होने के बावजूद, MD5 आज भी प्राथमिक हैश फंक्शन बना हुआ है - मुख्य रूप से गैर-क्रिप्टोग्राफिक उद्देश्यों के लिए: फाइल अखंडता जांच, चेकसम सत्यापन, डुप्लिकेट फाइल पहचान, और गैर-सुरक्षा-महत्वपूर्ण एप्लिकेशन।

क्या MD5 पासवर्ड के लिए अच्छा है?

नहीं! साल्टेड MD5 पासवर्ड का उपयोग करना अच्छा विचार नहीं है। ऐसा इसलिए नहीं है क्योंकि MD5 में क्रिप्टोग्राफिक कमजोरियां हैं, बल्कि इसलिए क्योंकि यह तेज है - एक GPU पर एक हैकर प्रति सेकंड अरबों पासवर्ड आज़मा सकता है। धीमे हैशिंग एल्गोरिदम का उपयोग करें: bcrypt, scrypt, PBKDF2, या Argon2।

फाइल का MD5 हैश क्या है?

MD5 इनपुट का 128-बिट मैसेज डाइजेस्ट (या फिंगरप्रिंट) उत्पन्न करता है। बड़े फाइलों वाले एप्लिकेशन में, MD5 हैश आउटपुट का उपयोग फाइलों की अखंडता सत्यापित करने के लिए डिजिटल हस्ताक्षर के रूप में किया जा सकता है।

PHP में MD5 का अर्थ

PHP में md5() फंक्शन स्ट्रिंग का MD5 हैश गणना करता है। RSA Data Security, Inc. द्वारा प्रदान किया गया। RFC 1321 के अनुसार: "MD5 मैसेज-डाइजेस्ट एल्गोरिदम किसी भी लंबाई के संदेश को इनपुट के रूप में लेता है, और आउटपुट के रूप में इनपुट का 128-बिट फिंगरप्रिंट या 'मैसेज डाइजेस्ट' उत्पन्न करता है।"

MD5 मान क्या है?

MD5 चेकसम एक 32-कैरेक्टर हेक्साडेसिमल नंबर है जो एक फाइल पर गणना की जाती है। यदि दो फाइलें MD5 चेकसम मान साझा करती हैं, तो वे समान होने की संभावना है। वैकल्पिक सॉफ्टवेयर इंस्टॉलेशन पैकेज डाउनलोड करने के बाद आप इंस्टॉलेशन फाइल पर MD5 चेकसम गणना कर सकते हैं।

MD5 गणना में कितना समय लगता है?

आमतौर पर, NC एक आइटम को 3-4 घंटे में स्थानांतरित करता है, और फिर MD5sum 40 मिनट में प्राप्त होता है।

विंडोज 10 पर MD5 चेकसम कैसे गणना करें?

  1. Windows कमांड लाइन खोलें (Win+R, cmd टाइप करें, Enter दबाएं)
  2. फाइल वाले फोल्डर में जाएं
  3. टाइप करें: certutil -hashfile <फाइलनाम> MD5
  4. Enter दबाएं
  5. परिणामी चेकसम की तुलना अपेक्षित चेकसम से करें

MD5 का उद्देश्य

प्रारंभ में डिजिटल हस्ताक्षर प्रमाणित करने के लिए एक सुरक्षित क्रिप्टोग्राफिक हैशिंग एल्गोरिदम के रूप में डिज़ाइन किया गया। हालांकि, MD5 अब अनजाने डेटा भ्रष्टाचार का पता लगाने और डेटा अखंडता सत्यापित करने के अलावा किसी भी उपयोग के लिए अनुशंसित नहीं है।

आधुनिक विकल्प

उपयोग मामलाअनुशंसित एल्गोरिदम
पासवर्ड हैशिंगbcrypt, scrypt, Argon2, PBKDF2
डिजिटल हस्ताक्षरSHA-256, SHA-3, Ed25519
फाइल अखंडताSHA-256, BLAKE2, SHA-3
SSL/TLS प्रमाणपत्रSHA-256, SHA-384
  1. - नेटवर्क सिक्योरिटी क्या है?

    नेटवर्क सिक्योरिटी: परिभाषा, प्रकार, महत्व और कार्यप्रणाली नेटवर्क सिक्योरिटी समझाइए? नेटवर्क सिक्योरिटी से कंपनी अपने इंफ्रास्ट्रक्चर और उपयोगकर्ताओं की रक्षा करती है, संभावित हानिकारक खतरों को नेटवर्क में प्रवेश/प्रसार से रोककर। नेटवर्क सिक्योरिटी क्या है और कैसे काम करती है? विभिन्न सुरक्षा खतर

  1. - नेटवर्क सिक्योरिटी ID क्या है? (नेटवर्क सिक्योरिटी की से अंतर)

    नेटवर्क सिक्योरिटी ID vs नेटवर्क सिक्योरिटी की - भ्रम दूर करें अक्सर लोग नेटवर्क सिक्योरिटी ID और नेटवर्क सिक्योरिटी की (की) में भ्रमित होते हैं। ये अलग-अलग चीजें हैं: नेटवर्क सिक्योरिटी की (Network Security Key) - वास्तविक पासवर्ड क्या है: आपके वाई-फाई नेटवर्क का पासवर्ड (WPA/WPA2/WPA3 की)। अन्य

  1. - नेटवर्क सुरक्षा क्या है?

    नेटवर्क सुरक्षा: परिभाषा, प्रकार, महत्व और कार्यविधि नेटवर्क सुरक्षा हार्डवेयर, सॉफ्टवेयर और नीतियों का संयोजन है जो नेटवर्क और डेटा को अनधिकृत पहुंच, दुरुपयोग, खराबी, संशोधन, विनाश या अनुचित प्रकटीकरण से बचाता है। नेटवर्क सुरक्षा का क्या अर्थ है? जब भी आप किसी सुरक्षा गतिविधि में भाग लेते हैं, तो