आपने हाल ही में Google Play Store से एक ईमेल प्राप्त किया होगा जिसमें निम्नलिखित कहा गया है:
अपने Play Core Maven डिपेंडेंसी को Android 14 संगत संस्करण में अपडेट करें! आपका वर्तमान Play Core लाइब्रेरी targetSdkVersion 34 (Android 14) के साथ असंगत है, जो उपयोगकर्ता सुरक्षा में सुधार के लिए ब्रॉडकास्ट रिसीवर्स में एक बैकवर्ड-इनकम्पैटिबल बदलाव पेश करता है। एक अनुस्मारक के रूप में, 31 अगस्त से, Google Play को सभी नए ऐप रिलीज के लिए Android 14 को लक्षित करने की आवश्यकता है। ऐप क्रैश से बचने के लिए नवीनतम Play Core लाइब्रेरी संस्करण डिपेंडेंसी में अपडेट करें: https://developer.android.com/guide/playcore#playcore-migration
आप इस SDK संस्करण के साथ अपने ऐप के भविष्य के संस्करणों को प्रोडक्शन या ओपन टेस्टिंग में जारी नहीं कर पाएंगे।
डरावना लगता है, है ना?
इतना चिंतित न हों। यह वास्तव में जितना दिखता है उससे आसान है।
यह बदलाव वास्तव में किस बारे में है
मूल रूप से, Google ने 2022 की शुरुआत में Play Core लाइब्रेरी के नए संस्करण जारी करना बंद कर दिया।
Play Core लाइब्रेरी का जारी किया गया अंतिम संस्करण
और अप्रैल 2022 से, उन्होंने मूल Play Core लाइब्रेरी को चार अलग-अलग लाइब्रेरी में विभाजित कर दिया है:
- Play Assets Delivery Library
- Play Feature Delivery Library
- Play In-App Reviews Library
- Play In-App Updates Library
प्रत्येक लाइब्रेरी की अपनी कार्यक्षमता और जिम्मेदारी है।
चूंकि पुरानी कोर Play लाइब्रेरी केवल एक निश्चित API स्तर तक का समर्थन करती है, आपको अपने एप्लिकेशन को नई लाइब्रेरी का उपयोग करने के लिए माइग्रेट करने की आवश्यकता है जिनमें सबसे हाल के API स्तरों के लिए समर्थन है।
संक्षेप में, आपको यह पता लगाने की आवश्यकता है कि आप मूल कोर Play लाइब्रेरी की किस कार्यक्षमता का उपयोग कर रहे हैं और फिर सही भाग डाउनलोड करें। उदाहरण के लिए, यदि आपके पास उपयोगकर्ताओं को सूचित करने का तर्क था जब आपके एप्लिकेशन का एक नया संस्करण उपलब्ध था, तो आपको Play In-App-Updates लाइब्रेरी लेने की आवश्यकता है।
हम यहां दो उपयोग के मामले प्रस्तुत करेंगे:
- नेटिव Android एप्लिकेशन
- Flutter एप्लिकेशन
उपयोग का मामला - नेटिव Android ऐप
यदि आपके पास एक नेटिव Android एप्लिकेशन है, चाहे वह Kotlin या Java में लिखा गया हो, तो आपको निम्नलिखित करने की आवश्यकता है:
- अपने एप्लिकेशन लेवल build.gradle फाइल खोलें
- सबसे अधिक संभावना है कि आप डिपेंडेंसी ब्लॉक के तहत यह लाइन देखेंगे:
implementation 'com.google.android.play:core-ktx:1.8.1'
आपको इसे हटाने और पिछली कोर लाइब्रेरी में आपने क्या उपयोग किया था, उसके अनुसार इसे बदलने की आवश्यकता होगी
यदि आपको Play In-App-Updates लाइब्रेरी लेने की आवश्यकता है, तो आपको डिपेंडेंसी ब्लॉक में इन्हें जोड़ने की आवश्यकता है:
implementation 'com.google.android.play:app-update:2.1.0' // यदि आप अपने एप्लिकेशन में Kotlin का उपयोग कर रहे हैं तो नीचे दी गई डिपेंडेंसी जोड़ें implementation 'com.google.android.play:app-update-ktx:2.1.0'
- अपने एप्लिकेशन को पुनः बनाएं और देखें कि सब कुछ वैसा ही काम करता है जैसा होना चाहिए।
✋ आपको आयात विवरणों को import com.google.android.play.core.tasks.*; से import com.google.android.gms.tasks.*; में बदलने की भी आवश्यकता हो सकती है।
उपयोग का मामला - Flutter एप्लिकेशन
चूंकि Flutter एक फ्रेमवर्क है जो Android और iOS दोनों को पूरा करता है, यह परिदृश्य ऊपर वाले से थोड़ा अलग है। यदि आपको अपने Flutter एप्लिकेशन में कोर प्ले लाइब्रेरी को अपग्रेड करने की चेतावनी मिलती है, तो आपको अपने pubspec.yaml फाइल में उपयोग की जा रही लाइब्रेरी को देखने की आवश्यकता है:
dependencies: flutter: sdk: flutter ... in_app_update: ^3.0.0
जैसा कि आप ऊपर देख सकते हैं, एप्लिकेशन in_app_update लाइब्रेरी पर निर्भर करता है, जिसका संबंध उपयोगकर्ताओं को सूचित करने से है जब एप्लिकेशन का एक नया संस्करण उपलब्ध होता है। जब हम in_app_update के pub.dev चेंजलॉग पेज पर जाते हैं, तो हम देख सकते हैं कि:
संस्करण 4.1.0 ने आवश्यक समर्थन जोड़ा
इसलिए हमें अपने pubspec.yaml फाइल को उस संस्करण (कम से कम) का उपयोग करने के लिए अपडेट करने की आवश्यकता है।
dependencies: flutter: sdk: flutter ... in_app_update: ^4.1.0
Pub get चलाएं और आप जाने के लिए तैयार हो जाएंगे।
मुफ्त में कोड करना सीखें। freeCodeCamp का ओपन सोर्स पाठ्यक्रम 40,000 से अधिक लोगों को डेवलपर्स के रूप में नौकरी पाने में मदद कर चुका है। शुरू करें